Dell OptiPlex GX1 funciona con circuito integrado de sonido Crystal Semiconductor CS4236B-KQ

Enviado por siddharta el 30 Marzo, 2009 - 18:29.

speaker.png

QUÉ HICE

Este fin se semana (domingo 29 de marzo de 2009) instalé Kubuntu 8.04 (Hardy Heron) en un equipo Dell OptiPlex GX1. Es un equipo que salió al mercado alrededor de 1999/2000, y algunas de sus características a simple vista son:

  • procesador: Intel Pentium 3 @ 450 MHz
  • memoria: 128 MB
  • disco duro: Maxtor de 06 GB
  • red: Ethernet 10/100 Mbps
  • unidades: CD-ROM y Floppy Disk Drive de 3.5"

El equipo funciona muy bien, la memoria la aumenté a 512 MB, y cambié el CD-ROM por un DVD-ROM/CD-RW. Sin embargo no funcionó el sonido tras la instalación, y a continuación explico cómo lo solucioné.

CÓMO LO HICE

"En primer lugar, publiqué muchos mensajes en distintos foros con el título: AYUDAAAAAAAA, POR K NO ME ACE SONIDOS 'EL KUBUNTU'?? SERA BIRUS?? URRGEEE ... MUXAS GRAX !!!! (así en mayúsculas, con faltas de ortografía, con abreviaciones tipo SMS, y de manera exigente). Después de esperar muchas horas y ver que nadie me contestaba concluí que "Linucs no sirve" y formateé el equipo e instalé MS Windows 2000 ... por septuagésima vez." <--- ¡Mentira!

En primer lugar tomé nota de los datos del hardware, como marca y modelo. Posteriormente quité la tapa del equipo para leer el circuito integrado de audio (Crystal CS4236B-KQ). Ya con esos datos usé el buscador Google y encontré varios sitios (al final cito las fuentes) que me permitieron configurar el audio, y lo resumo así:

a) Es necesario destapar el equipo y leer el circuito integrado, en el caso de mi equipo mencionado, el circuito dice Crystal CS4236B-KQ.

b) Consultar la lista que muestra los nombres de los módulos controladores, en esa lista encontré la siguiente línea, la cual corresponde con el circuito integrado de mi equipo:

snd-cs4236= Generic driver for CS4235/6/7/8/9 chips

c) Abrir una ventana de terminal y :

El comando siguiente (modprobe) permite al kernel probar el módulo (controlador) indicado. Debe ser ejecutado con privilegios de superusuario (sudo):

sudo modprobe snd-cs4236

El comando siguiente visualiza una mezcladora de sonido, con diversos controles. Al oprimir las teclas flecha hacia arriba y flecha hacia abajo se observa que los controles ascienden y descienden, lo cual es buena señal. No hay que configurar nada ahí, sólo es para probar. Para salir se presiona la tecla ESC. Si alsamixer no se ejecuta entonces el módulo seleccionado anteriormente no es el correcto:

alsamixer

Posteriormente se cierra el icono de Kmix (la bocina junto al reloj en el panel de tareas), y se vuelve a ejecutar desde el menú K en la categoría Multimedia. Si todo está bien entonces es posible usar el reproductor de música favorito.

Para que la configuración fuese permanente tuve que modificar el archivo /etc/modules, al cual únicamente agregué el nombre del módulo, al final del archivo. De no modificar dicho archivo, la próxima vez que el equipo reiniciase estaría sin audio. En mi caso el archivo quedó así:

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

fuse
lp
snd-cs4236

¡Listo!, conecté un par de bocinas, ejecuté amarok y las primeras notas en salir del equipo fueron de una versión instrumental para piano de "Bésame mucho", de la señora Consuelo Velázquez. Simplemente bello.

ACTUALIZACION (2009-04-16):
En algunas ocasiones no pude reproducir música usando amarok, y aparecía el siguiente mensaje:

"xine was unable to initialize any audio drivers"

Xine es el motor de reproducción de audio que usa amarok.

Después de buscar en Internet encontré que el problema es ocasionado porque previamente se ha mostrado alguna página con algún video de Flash (.FLV) que muy probablemente tiene errores. La solución es cerrar amarok y el navegador (en mi caso Mozilla Firefox), posteriormente abrir en primer lugar amarok y después el navegador. Mejor aún, cerré todas las aplicaciones, ejecuté amarok y lo minimizé en la bandeja del sistema, posteriormente salvé mi sesión. Ahora cada vez que inicio sesión amarok se inicia, posteriormente yo abro el navegador.

POR QUÉ LO HICE

En enero 2009 los amantes de lo ajeno perpetraron un robo en mi casa, y se llevaron -entre otras cosas- mi equipo portátil, una Compaq Presario M2015LA. Tengo conexión a Internet, pero me quedé sin equipo.

Mis actividades laborales requieren que pueda tener acceso a Internet, pues a veces debo conectarme a los servidores de la oficina para revisar procesos, respaldos, servicios de correo, etc. Por lo anterior, la empresa donde laboro me prestó un equipo, mientras ahorro para comprarme otro equipo portátil. El equipo prestado no es lo último en tecnología, pero para mí eso es más que suficiente, sin embargo no quise privarme de escuchar música mientras lo uso.


fuentes:
Ubuntu forums, Comprehensive Sound Problem Solutions Guide:
http://ubuntuforums.org/showthread.php?t=205449

Ubuntu documentation, HOWTO setup sound cards:
https://help.ubuntu.com/community/HowToSetupSoundCards

IceWalkers, The Linux BootPrompt HOWTO:
http://www.icewalkers.com/Linux/Howto/BootPrompt-HOWTO-8.html

Imagen de stalker
Enviado por stalker el 30 Marzo, 2009 - 18:38.
siddharta escribió:

"En primer lugar, publiqué muchos mensajes en distintos foros con el título: AYUDAAAAAAAA, POR K NO ME ACE SONIDOS 'EL KUBUNTU'?? SERA BIRUS?? URRGEEE ... MUXAS GRAX !!!! (así en mayúsculas, con faltas de ortografía, con abreviaciones tipo SMS, y de manera exigente). Después de esperar muchas horas y ver que nadie me contestaba concluí que "Linucs no sirve" y formateé el equipo e instalé MS Windows 2000 ... por septuagésima vez." <--- ¡Mentira!

meparto ¡Muy bueno! Pero no me voy a quedar sólo en la anécdota... No sería justo después de un hilo tan bueno. Creo que la estructura ¿qué hice?, ¿cómo lo hice? y ¿por qué lo hice? que has dado al blog, es todo un acierto. Enhorabuena por tu trabajo wink

Imagen de Viorel
Enviado por Viorel el 30 Marzo, 2009 - 22:35.

Muy buen articulo como siempre Siddharta clap clap

Yo creo que en el mensaje que enviaste al foro nadie te contesto porque no subiste el hilo cada 20 minutos eyebrows

Ya en serio, concuerdo con Stalker sobre la estructura que has puesto al blog.

Felicidades.

Imagen de shaola
Enviado por shaola el 30 Marzo, 2009 - 22:44.

yo tambien, pero no se me ocurre nada original que no hayan dicho ya...
felicidades!

Imagen de maalmike
Enviado por maalmike el 2 Abril, 2009 - 07:09.

Ya se ha dicho todo, solo queda darte un aplauso y una felicitación. clap

Imagen de siddharta
Enviado por siddharta el 2 Abril, 2009 - 14:57.

Gracias a todos por sus comentarios y palabras de aliento :) , la estructura que pensé para el blog les confieso que fue porque no se me ocurrió algo mejor, al ver los blogs de ustedes mis compañeros creí que en mi caso lo más conveniente sería ir exponiendo los problemas a los que me enfrento y cómo los resuelvo, esperando servir de guía a alguien más. También lo hago porque la mayoría de la documentación que uso está en inglés y al no encontrar equivalentes en español entonces plasmo la idea en este idioma.

Un saludo a todos y nuevamente gracias por leerme.

Imagen de Anarcxpoll
Enviado por Anarcxpoll el 9 Abril, 2009 - 10:18.

Muy buen post siddharta, no sabía que también tenias blog! clap

siddharta escribió:

AYUDAAAAAAAA, POR K NO ME ACE SONIDOS 'EL KUBUNTU'?? SERA BIRUS?? URRGEEE ... MUXAS GRAX !!!!

meparto meparto meparto

Imagen de PabliNet
Enviado por PabliNet el 21 Marzo, 2010 - 03:38.

No conocía este entrada, muy buena.

Siddharta escribió:

Después de buscar en Internet encontré que el problema es ocasionado porque previamente se ha mostrado alguna página con algún video de Flash (.FLV) que muy probablemente tiene errores. La solución es cerrar amarok y el navegador (en mi caso Mozilla Firefox), posteriormente abrir en primer lugar amarok y después el navegador. Mejor aún, cerré todas las aplicaciones, ejecuté amarok y lo minimizé en la bandeja del sistema, posteriormente salvé mi sesión. Ahora cada vez que inicio sesión amarok se inicia, posteriormente yo abro el navegador.

Creo que ya tenés máquina nueva, pero quizás solucionabas este problema eliminando el paquete pulseadio.

Imagen de siddharta
Enviado por siddharta el 22 Marzo, 2010 - 03:07.
PabliNet escribió:

[...] Creo que ya tenés máquina nueva, pero quizás solucionabas este problema eliminando el paquete pulseadio.

Aún tengo la máquina, pero ya no tiene Kubuntu 8.04 sino Debian 5 (lenny), y en dicha instalación no está instalado pulseaudio de manera predeterminada ... de hecho no sabría decirte en este momento si el audio funciona con esta instalación de Debian ya que sólo hice la instalación normal y de inmediato le quité el monitor, y lo metí debajo de una mesa pues ahora es un servidor web casero .... lo configuro vía SSH y por ello mismo no requiero de audio.

Saludos Pablinet, gracias por el tip en caso de que vuelva a instalarle Kubuntu 8.04.

Imagen de djcriss
Enviado por djcriss el 12 Octubre, 2011 - 00:08.

hola hice lo que dices para poder tener audio, y pues si logre activar el audio como tu dices pero la verdad no entiendo como guardar la configuracion de /etc/modules me puedes ayudar? tengo una dell optiplex gx1 y tengo sistema operativo lubuntu nada mas que no tengo idea de como guardar la configuracion gracias

Imagen de siddharta
Enviado por siddharta el 19 Octubre, 2011 - 15:08.
djcriss escribió:

[...] no entiendo como guardar la configuracion de /etc/modules me puedes ayudar? tengo una dell optiplex gx1 y tengo sistema operativo lubuntu nada mas que no tengo idea de como guardar la configuracion gracias

Eres libre de utilizar el editor de texto que tú prefieras, por ello sólo indiqué que hay que agregar "snd-cs4236" en la última línea del archivo /etc/modules. Yo uso la línea de comandos, así:

1)

$ sudo nano /etc/modules

2) ve al final del archivo y escribe en una línea nueva snd-cs4236

3) presiona CTRL+X (que significa eXit, es decir, salir del editor nano)

4) presiona Y (yes) o S (sí), para indicar que sí deseas guardar los cambios

5) presiona Enter para conservar el mismo nombre de archivo

También puedes usar un editor de texto gráfico, como Kate o Kwrite, así:

$ kdesudo kate /etc/modules

o

$ kdesudo kwrite /etc/modules

Tienes suerte de que entré a Kubunt-es.org a buscar un tema, de lo contrario no habría visto que escribiste un comentario en el blog que llevaba. Actualmente ya no agrego contenido aquí, pues instalé mi propio blog en http://sidd.homelinux.net/

Saludos, me da gusto que el artículo te haya sido útil :)
Sidd.